Adobe Acrobat 15
13 replies, 1148 views
Posted on June 26, 2015
forrest.frey@fortiline.com
Registered user
Joined: March 31, 2014

Has anyone successfully layered Acrobat 15.  I have tried many times, and many things, but each time it asks the user to logon with an Adobe Cloud account.  We use an open license so our users should not need to logon to use the product.

 

Any help will be greatly appreciated.

 

 

Posted on June 26, 2015
Rob Zylowski
Unidesk employee
Joined: June 21, 2010

Forest adobe has a serializer utility that allows you to script entering the license.  You have to use that wiht a cmd script that runs during the build process.  The process is dicusseed in our adobe apps recipe.

Posted on June 26, 2015
FCOETech
Registered user
Joined: April 15, 2013

Hi Forrest,

Definitely lots of good info in the recipe - check it out! It does reference the enterprise activation methods, which should work for you.

https://helpx.adobe.com/creative-cloud/packager/provisioning-toolkit-enterprise.html

We had some difficulty getting this to run/work in the layer; the activation worked in the install machine but did not stick after deployment to the user. So we just deployed a policy to run the activation at login instead. Here's how we did it. There are more options and a lot of flexibility in the tool - YMMV!

Install your Adobe application. Download and install the adobe_prtk from the references in the article above. You then need to use this tool to generate a validation file, and then use the tool to activate against it. The validation file is called "prov.xml". First we generate the file, then we put the tool and the prov file in root or the app folder of the appl layer during install so it's there after deployment. Then we use a logon script to run the activation after the user logs in. We filter the policy to indiviudals licensed to use the product. 

To generate prov.xml:

- Copy adobe_prtk to c:\
- Run the following from c:\
adobe_prtk --tool=VolumeSerialize --generate --serial=xxxx-xxxx-xxxx-xxxx-xxxx-xxxx --leid=[this should match your product] --regsuppress=ss --eulasuppress
 
To serialize:
- Copy prov.xml to c:\ 
- Run the following from c:\
adobe_prtk --tool=VolumeSerialize --provfile="c:\prov.xml"
 
We do the serializing as a small logon script:
__
@echo on
cls
 
cd /d "c:\"
adobe_prtk --tool=VolumeSerialize --provfile="c:\prov.xml" --regsuppress=ss
 
EXIT

__

Probably more clunky than it needs to be, but it has worked well for us.

Posted on January 26, 2016
Edited by Blake Gore on January 26, 2016
Blake Gore
Registered user
Joined: July 26, 2013

Awesome post. This helped me get our problem with Adobe Acrobat DC Pro fixed. Our problem was that the users kept getting prompted to log in to the Adobe Document Cloud. I didn't want to have to manage every account. I would just prefer to turn off the login prompt.

Here's what I did in our environment:

Edited the Adobe Acrobat DC Pro layer to run the following script in Unidesk:

C:\windows\setup\Scripts\kmsdir\adobe\serialize.cmd

In that .cmd, I do the following: 

"@echo on
cls

cd /d "C:\Windows\Setup\scripts\kmsdir\Adobe"
adobe_prtk.exe --tool=VolumeSerialize --provfile="C:\Windows\Setup\scripts\kmsdir\Adobe\prov.xml" --regsuppress=ss"
 
Inside C:\windows\setup\Scripts\kmsdir\adobe, I have the serialize.cmd, prov.xml and the adobe_prtk.exe
 
 
To generate the prov.xml, I downloaded Adobe Provisioning Toolkit Enterprise Edition v9 then ran the following command:
adobe_prtk --tool=VolumeSerialize --generate --serial=<ADOBE DC PRO KEY> --leid=[V7{}AcrobatESR-12-Win-GM] --regsuppress=ss --eulasuppress

Incidentally, this also seemed to work on my Adobe Acrobat DC Standard layer as well.
 

Posted on February 5, 2016
FCOETech
Registered user
Joined: April 15, 2013

Thanks for the feedback, Blake! I'm glad this helped. We've been a little nervous about the serialization option being cut from future releases. They keep hinting at the possibility but so far we've been able to work around it with the method you used.

Are you a Creative Cloud for Teams/Enterprise customer? Have you tried deploying other apps from Creative Cloud using the above method (Photoshop, Illustrator, etc.)? We do have a handful of users who purchased these and for those, I actually do allow registration and activation to be handled through the CC agent and with an Adobe ID login that we set up and attach to an org email. We have so few users who buy these licenses it's easier that way at the moment. 

Posted on December 29, 2016
David Thacker
Registered user
Joined: September 27, 2016

This works perfectly! The only thing I have to add is to make sure you have a recent version of the adobe_prtk tool. I had version 6, and it kept throwing errors that it couldn't find the prov.xml file while trying to create it. I got a copy of version 9 of the tool from our Adobe licensing portal, and it created the prov.xml without issue.

Posted on July 1, 2015
forrest.frey@fortiline.com
Registered user
Joined: March 31, 2014

Thanks for the information guys.

Rob,  does setupcomplete.cmd run one time or everytime the machine is re-biced?

FCOETech, is this setup for persistent or non-persistent desktops?

 

Thanks again.

 

 

Posted on July 1, 2015
Rob Zylowski
Unidesk employee
Joined: June 21, 2010

Hi Forest if you use setupcomplete it is only for new desktops when building them.  For non persistent desktops you should do it this way to make sure you only use a license once and it gets in to the desktop while it is still persistent otherwise it will take a license every boot.  The just rebuild the NP desktops.

For persistent desktops you can run that license script lots of ways.  You can use our script entry in the UI which will run a script just once after applying a layer. That gets called at boot from the kmssetup.cmd file in the kmsdir folder. If you are using the more experimental unattend 4.7 you can add it to the system runonce folder.

Rob

Posted on January 6, 2017
lukaszdziwisz@alpinebank.com
Registered user
Joined: July 14, 2016

Hello guys,

Sorry to bring that out to live again but we are in the same boat now as well. We are trying to start using Adobe Acrobat DC and we are runing into couple of issues with that.

FIrst of all,

I have followed Blake's solution and serialized the installation of Adobe on installation machine. Then I created an Adobe directory in C:\windows\setup\Scripts\kmsdir\adobe and copied both prov.xml and the adobe_prtk.exe in there. Also, I have created serialize.cmd as follows:

"@echo on
cls

cd /d "C:\Windows\Setup\scripts\kmsdir\Adobe"
adobe_prtk.exe --tool=VolumeSerialize --provfile="C:\Windows\Setup\scripts\kmsdir\Adobe\prov.xml" --regsuppress=ss"
 
and saved it in C:\Windows\Setup\scripts\kmsdir\Adobe
 
Then I have finalized the layer. The problem is that when I apply that layer to myself, the serialize.cmd didn't run at all. Is this only going to be running when machine is built? I have run it manually and it seemed to work and serialized my Adobe but then this lead me to another issue - Adobe Sign in.
 
THe adobe sign in keeps popping up every time I open Acrobat. I can close out of it and still use my Acrobat, however next time I open it up it will pop up again.
 
Any help would be greatly appreciated?
Posted on January 6, 2017
Rob Zylowski
Unidesk employee
Joined: June 21, 2010

Did you remember to add your script path into the scriptpath for the layer?

That is what tells the boot scripts to run it.

Rob

Posted on January 6, 2017
lukaszdziwisz@alpinebank.com
Registered user
Joined: July 14, 2016

No I didn't do this. Can you refresh my memory on how to do this?

Posted on January 9, 2017
lukaszdziwisz@alpinebank.com
Registered user
Joined: July 14, 2016

What do you mean by add your script path into the scriptpath for the layer?

Do you mean to add it to the runonce folder?

Any help would be appreciated,

Posted on January 9, 2017
Blake Gore
Registered user
Joined: July 26, 2013

When creating the app layer, you must enter the path to the .cmd in the Script Path field. See below.

 

Posted on January 9, 2017
lukaszdziwisz@alpinebank.com
Registered user
Joined: July 14, 2016

Perfect. Thank you Blake. I didn't know about that.

Thank you very much. I really appreciate that

Login to post comments